CodeCode

なんか色々おぼえ書き。だいたいweb制作関連。

macOSをアップデートしたらGitが動かなくなった(2回目)

MacBookのmacOSをHigh SierraからMojaveにアップデートした。 その後、なぜかGitを使おうとすると以下のようなエラーが出る。 (SierraからHigh Sierraにアップデートしたときにも出くわした気がする)

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

エラーメッセージににもあるように、なぜか CommandLineToolsxcrun が見つからないと言われている。 理由は不明だが、コマンドラインツールをインストールし直せば解決する。

コマンドラインツールは、XcodeをMac App Storeでダウンロードして実行するか、ターミナルでコマンドを実行するとインストールできる。

xcode-select --install

ターミナルで、コマンドを実行すると、インストールしますかという確認と使用許諾契約のウィンドウが出てくるので、それぞれ インストール同意する を押すとインストールが始まる。

インストールの確認画面でインストールを押す

使用許諾契約に同意するとインストールが始まる

それが完了すると今まで通りGitが動くようになった。

トップへ戻る